Sticky

Have you found a bug? Please report it here 🙏

Have you found a bug? Please report it here 🙏
Userlevel 7
Badge +6

Please comment your bug in this post.

By collecting them in one place it’s easier for us to notify the relevant Developers Team and make sure things get fixed as fast as possible.

 

Save yourself time, make sure it’s an actual bug!

 

Are you a Developer?

If you’re a Developer yourself, it’s very likely you’ve heard of GitHub. Please report your bug on the Elementor GitHub to bring it to the attention of our Dev Team in the fastest way possible. 

 

Not finding what you need?

Please let us know in the comments. We’re happy to listen and improve.


87 replies

Userlevel 7
Badge +4

I use mailchimp a lot with clients and I have this issue with all of them.  I’ve added the API Key in the Integrations Settings, but it never loads the Audience by using Default (just spins forever).

 

this is the response 

 

Using Custom and the same API key it works ok and Audience list loads properly:

 

Userlevel 1

Prior to the 3.3.0 release, we used Elementor templates to save full-page layouts that were then applied to new pages, and then edited to meet the content needs of that page, while creating a base layer of consistency. With the 3.3.0 release, saved templates applied to new pages are no longer editable. I understand that this may be a desirable functionality for creating new Template Kits, but we don’t have a way of building pages using our saved templates now. Can you advise on how to still save sections that can be applied to other pages and edited on a page-by-page basis?

Can anyone tell me how to make my search widget work again? I use it so people can find relevant blog posts. It Looks like it’s going to do something but then just shows all the posts rather than a short list. This is the link https://www.jumbledbrain.com/blog/

Userlevel 2

I have the latest version of Elementor (3.3.0) and I can’t edit any existing image carousels, and if I try to create a new one, I can select images from my media gallery, but there is no button to Create a New Gallery, so I can’t add the images to the carousel.  I’ve tried in Chrome and Edge, same result.  I did just do the latest Elementor update today, so not sure if this is a bug? 

I have made a “back to top” icon that is on all pages.

I’ve used a rotating animated headline on one of the pages.  All words are one line only.

 

On the page with the rotating headline, on mobile view, the “back to top icon” jumps left and right and slightly up and down when the rotating headline changes to the last rotation.

Userlevel 3
Badge +1

Every time I try to access/apply one of the “Kit Library” Template Kits via my licensed/active Elementor Pro install,  Elementor tells me “Your license has exceeded the limitation.”

 

How can my license have exceeded its limitation when I’m trying to use the Template Kit via my licensed/activated - both CONFIRMED - site? 

 

Elementor’s “Customer Support” has been of no help/assistance with this issue for nearly a week.

 

:angry:

No Elementor bugs from me. Just 1 from this site.

 

On Mobile when in the side menu is open and you expand the Community drop down. You can’t see any of the lower menu items.

 

Scrolling is enabled, But it needs some padding or margin so you can reach the last menu item

Userlevel 1

Unable to add images to gallery. After selecting images to the gallery widget, I do not have the “Create a New Gallery” button on the lower right section. Therefore I am unable to add pictures to a gallery. I use Safari but I faced the same issue on Google Chrome. Not sure what else to do. Also, none of the templates load for me.

Badge

Are you aware of an issue since the newest update of Google Chrome for Mac OS X? I updated today and since then Elementor isn't loading, even your website Elementor.com isn't loading and I can't log in to my Elementor Account. 

Hi all!
Custom atributes 
it does not work, apply the key attribute in a grandparent, not in a element.
data-spots|round in h1

html result:
<div class="elementor-element…" data-spots="round">
      <div class="elementor-widget-container">
             <h1>"some text"

Hi, I’m having issues creating pages/page templates with Elementor Pro. 

 

For reference, I have a custom made theme, which I’d like to keep as I’m happy with my existing pages.  However, I’d be looking to add a page each week, which would be easier to do with Elementor (rather than creating new page templates with my theme).

 

When making single-page templates/adding pages, it pulls through my header & footer from my custom theme automatically, which is fine, however the header seems to overlap the content space at the top, which looks wrong.

 

To add to this, when I click the + button to add further content space, this will appear at the top of the page (overlapped by the header).

 

Aside from this, even with the ‘elementor full width’ layout, there still seems to be white space around the content.

 

I’ve attached a doc with some screenshots too, but if anyone can offer any guidance that’d be great!

 

 

Best

Sam

 

Nothing has worked properly on my site since Sunday. I can work in the plugin (have Pro) editing and building, all the global widgets work in the builder but not at all in a live capacity.

I have reached out to support every day, no response. If this is still the case tomorrow we’ll need to go with another product.

 

 

hello

i’m quite new at this and i was building my website.

all wonderful, except that was some kind of bug and there is a block that losted is editable capacity and is stuck at the home page and all the rest because is connected somehow with the footer.

with the html inspect page from the browser I could identify and delete that block, but doesn't affect the page html.

is there some option to edit the damn page and remove that block?

i need help!!!

thank you!

Grids are broken for product archive page, now shows in one column with huge images, please fix this as soon possible , it seems to be missing css to make it grid with rows and columns. ahahahhhhhh

Hallo, 

nach der Aktualisierung hat Elementor mein Theme verändert. Alte Beiträge und Seite, welche mit den Wordpress-Blocks erstellt wurden, sehen jetzt furchtbar aus. Die Zeilenabstände und auch die Abstände bei den Abschnitten sind extrem verkleinert.

Beispiel Seite

Beispiel Beitrag

Was muss ich hier tun, damit wieder der CSS-Style von meinem Theme verwendet wird?

Danke. Sonnige Grüße Andrea

Userlevel 3

Elementor Pro 3.3.3 frontend.css is missing this code (and maybe more?) if I compare with 3.3.2

This is the reason why everybody is complaining about the huge images in woocommerce. Since there is no rollback feature on the pro plugin (You should add this!!) by adding this code to the customizer or site settings css temporarly fixed my problem but maybe other parts were left too… Please fix

@media (min-width: 1025px) {
.elementor-element.elementor-products-grid .woocommerce.columns-2 ul.products,.elementor-element.elementor-products-grid ul.products.columns-2 {
grid-template-columns:repeat(2,1fr)
}

.elementor-element.elementor-products-grid .woocommerce.columns-3 ul.products,.elementor-element.elementor-products-grid ul.products.columns-3 {
grid-template-columns: repeat(3,1fr)
}

.elementor-element.elementor-products-grid .woocommerce.columns-4 ul.products,.elementor-element.elementor-products-grid ul.products.columns-4 {
grid-template-columns: repeat(4,1fr)
}

.elementor-element.elementor-products-grid .woocommerce.columns-5 ul.products,.elementor-element.elementor-products-grid ul.products.columns-5 {
grid-template-columns: repeat(5,1fr)
}

.elementor-element.elementor-products-grid .woocommerce.columns-6 ul.products,.elementor-element.elementor-products-grid ul.products.columns-6 {
grid-template-columns: repeat(6,1fr)
}

.elementor-element.elementor-products-grid .woocommerce.columns-7 ul.products,.elementor-element.elementor-products-grid ul.products.columns-7 {
grid-template-columns: repeat(7,1fr)
}

.elementor-element.elementor-products-grid .woocommerce.columns-8 ul.products,.elementor-element.elementor-products-grid ul.products.columns-8 {
grid-template-columns: repeat(8,1fr)
}

.elementor-element.elementor-products-grid .woocommerce.columns-9 ul.products,.elementor-element.elementor-products-grid ul.products.columns-9 {
grid-template-columns: repeat(9,1fr)
}

.elementor-element.elementor-products-grid .woocommerce.columns-10 ul.products,.elementor-element.elementor-products-grid ul.products.columns-10 {
grid-template-columns: repeat(10,1fr)
}

.elementor-element.elementor-products-grid .woocommerce.columns-11 ul.products,.elementor-element.elementor-products-grid ul.products.columns-11 {
grid-template-columns: repeat(11,1fr)
}

.elementor-element.elementor-products-grid .woocommerce.columns-12 ul.products,.elementor-element.elementor-products-grid ul.products.columns-12 {
grid-template-columns: repeat(12,1fr)
}
}

 

I agree: I had the same problem after the update and would liked to have been able to roll back. This code fixed it for me in the meantime. Thank you!

Grettings,

Since Elementor 3.3.0 I’ve had problems with text extrance animations, in our case fadeInUp. I have custom code CSS to make the animation way more subtle than what can you set it to with Elementor only. This CSS isn’t working if upgrading to 3.3.0 or 3.3.1. I can still see the CSS when inspecting the element in the browser though.

Thank you in advance.

Looks like the fix was just sent out from Elementor. Pro Plugin Version 3.3.4. Just did the update and were back running smooth again!!!

Userlevel 2
Badge

July 20-21st 2021 the new update yesterday to adjust to WP 5.8 has created archive errors for woo commerce plugin users, the issue is that the update is displayingoversized single images of products in all archives and this is relating to search archives  and product archives. The products in archives are not displaying properly, and this issue is affecting probably all woo commerce users that use elementor page builder....please fix this, its a significant problem for live sites

Seems like the new Updated Version 3.3.4 launched today fixed the desktop resolution but, only if you adjust the categories count number too.Just changing the “Columns” number doesn’t instantly change it live, you must then adjust the “Categories Count” for it to adjust.  Also, the responsive mobile column doesn't adjust at all. Mine stays at 2 wide no matter what. Maybe 1 more update is needed for FULL Fix. Thanks 

Hi guys !

 

Since Wordpress 5.8 this morning I have issues that are really bad :(

 

I have a e-commerce and my category products doesn’t fit anymore with the settings I made. I always had 4 products on a line, the setting is still here but now there’s one product on every line and they’re huge !

 

It’s awfull for my customers, hope it will be fix soon.

 

To see an exemple : https://www.la-box-naturelle.fr/categorie-produit/chien/friandises_chien/

 

Thank you :)

Userlevel 2
Badge

Yea everyone using woo commerce and elementor is experiencing this error, and they have not fixed it, someone mumbled something about a 3.3.4 fix but there is no new update in the folder so that hasn't happend yet, im assuming this is hitting thousands or tens of thousands of sites across the web..

I have had similar to some of the issues listed above. Since the update, and the WP update. 

Everything works in the builder, and then logos and images go huge in live mode. I built a header template, and the template does something different on every page. I’ve started again a few times and it does misbehave consistently.

Any images I load, in the Flip or Image widget are black and white only and load at random sizes, even when I set the parameters at every level.

The Flip Widget in general is misbehaving. It’s extended and glitchy and piles on top of each other off to the left off of the page. This is setting 4 in one column in Align, with Space Between in the main column advanced settings. 

Global Widgets disappear, delete themselves….. 

I’ve gone through the Theme level, the Global settings through both Elementor and WP and the Theme of WP. I did find that these settings were fighting each other instead of being overridden, so a number of small issues were occurring. 

If it’s me, I will get back to work….. If it’s these two updates at war with me…. sigh…..

Having multiple issues with Elementor 3.3.1 and Elementor 3.3.4 of PRO. This also occurred with 3.3.3

Image Galleries are not showing up on the page but showing in JS preview. 

Also using Ele Custom Skin 3.1.1 and the loop for projects is showing in the JS preview but not on the page. 

Below is the error messages from Chome 91.0.4472. Hope this helps.

jquery.min.js:2 jQuery.Deferred exception: this.$element.sticky is not a function TypeError: this.$element.sticky is not a function
at child.activate (https://midsouthscreens.com/wp-content/plugins/elementor-pro/assets/js/frontend.min.js?ver=3.3.4:2:26467)
at child.e.each.n.<computed> [as activate] (https://midsouthscreens.com/wp-content/plugins/elementor/assets/js/frontend-modules.min.js?ver=3.3.1:2:42981)
at child.run (https://midsouthscreens.com/wp-content/plugins/elementor-pro/assets/js/frontend.min.js?ver=3.3.4:2:26794)
at child.e.each.n.<computed> [as run] (https://midsouthscreens.com/wp-content/plugins/elementor/assets/js/frontend-modules.min.js?ver=3.3.1:2:42981)
at child.onInit (https://midsouthscreens.com/wp-content/plugins/elementor-pro/assets/js/frontend.min.js?ver=3.3.4:2:27215)
at child.e.each.n.<computed> [as onInit] (https://midsouthscreens.com/wp-content/plugins/elementor/assets/js/frontend-modules.min.js?ver=3.3.1:2:42981)
at child.Module.trigger (https://midsouthscreens.com/wp-content/plugins/elementor/assets/js/frontend-modules.min.js?ver=3.3.1:2:44357)
at child.e.each.n.<computed> [as trigger] (https://midsouthscreens.com/wp-content/plugins/elementor/assets/js/frontend-modules.min.js?ver=3.3.1:2:42981)
at init (https://midsouthscreens.com/wp-content/plugins/elementor/assets/js/frontend-modules.min.js?ver=3.3.1:2:43142)
at child.Module (https://midsouthscreens.com/wp-content/plugins/elementor/assets/js/frontend-modules.min.js?ver=3.3.1:2:44435) undefined
Uncaught TypeError: this.$element.sticky is not a function
at child.activate (frontend.min.js?ver=3.3.4:2)
at child.e.each.n.<computed> [as activate] (frontend-modules.min.js?ver=3.3.1:2)
at child.run (frontend.min.js?ver=3.3.4:2)
at child.e.each.n.<computed> [as run] (frontend-modules.min.js?ver=3.3.1:2)
at child.onInit (frontend.min.js?ver=3.3.4:2)
at child.e.each.n.<computed> [as onInit] (frontend-modules.min.js?ver=3.3.1:2)
at child.Module.trigger (frontend-modules.min.js?ver=3.3.1:2)
at child.e.each.n.<computed> [as trigger] (frontend-modules.min.js?ver=3.3.1:2)
at init (frontend-modules.min.js?ver=3.3.1:2)
at child.Module (frontend-modules.min.js?ver=3.3.1:2)
frontend.min.js?ver=3.3.4:2 Uncaught TypeError: this.$element.sticky is not a function
at child.activate (frontend.min.js?ver=3.3.4:2)
at child.e.each.n.<computed> [as activate] (frontend-modules.min.js?ver=3.3.1:2)
at child.run (frontend.min.js?ver=3.3.4:2)
at e.each.n.<computed> (frontend-modules.min.js?ver=3.3.1:2)
at dispatch (jquery.min.js:2)
at v.handle (jquery.min.js:2)
common.min.js?ver=3.3.1:2 Uncaught ReferenceError: originalEvent is not defined
at onError (common.min.js?ver=3.3.1:2)
at dispatch (jquery.min.js:2)
at v.handle (jquery.min.js:2)
frontend.min.js?ver=3.3.4:2 Uncaught TypeError: this.$element.sticky is not a function
at child.activate (frontend.min.js?ver=3.3.4:2)
at child.e.each.n.<computed> [as activate] (frontend-modules.min.js?ver=3.3.1:2)
at child.run (frontend.min.js?ver=3.3.4:2)
at e.each.n.<computed> (frontend-modules.min.js?ver=3.3.1:2)
at dispatch (jquery.min.js:2)
at v.handle (jquery.min.js:2)
activate @ frontend.min.js?ver=3.3.4:2
e.each.n.<computed> @ frontend-modules.min.js?ver=3.3.1:2
run @ frontend.min.js?ver=3.3.4:2
e.each.n.<computed> @ frontend-modules.min.js?ver=3.3.1:2
dispatch @ jquery.min.js:2
v.handle @ jquery.min.js:2
common.min.js?ver=3.3.1:2 Uncaught ReferenceError: originalEvent is not defined
at onError (common.min.js?ver=3.3.1:2)
at dispatch (jquery.min.js:2)
at v.handle (jquery.min.js:2)

 

Reply