Question

IMG SRCSET ISSUES - Elementor v3.4.2 + Elementor Pro v3.3.7 Update Issues

  • 20 August 2021
  • 4 replies
  • 197 views

I’ve encountered another major issue with the most recent updates to Elementor v3.4.1 (now 3.4.2) and Elementor Pro 3.3.7.  None of my image srcsets are available to browsers after this update - leaving only full size image to be loaded.  This is obviously a huge problem that impacts load times tremendously.  Has anyone else had an issue with their image srcsets not loading after this update?

 

After running into this issue, I restored a backup & attempted to update again on staging site after 3.4.2 was released monday.  Still, same issue.  Very frustrating!

 

Relevant info:  I used the plugin Perfect Images (formerly Retina 2x) for generation of retina imgs and Siteground’s SG Optimizer to bulk generate webp imgs.  (on a side note & head’s up: SG Optimizer will NOT generate webp images of any file with the @2x suffix - so you must generate these manually (webpShop extension for photoshop)!

 

Thanks to the team for finally including a heads up regarding this update - it would have been nice to have included this warning earlier/initially.  Sunday night was a headache.  How is it that Elementor Pro is flagged as having unknown compatibility?

  

 

Regards,

Chase


4 replies

existing srcsets - before update
missing srcsets - after update

 

Not sure if you’ve solved this, but I’m running into a similar issue. Also using Perfect Images. 

For me, the issue appears related to dynamically inserted images, such as using the Featured Images widget or using a dynamically inserted ACF image field. 

The dynamic fields are not returning as responsive. Images that are embedded in the regular post body are returning as responsive. 

Not sure if that’s related to what you’re seeing. I haven’t found a solution yet, though. 

quick update & great news:  responsive img srcset issue fixed

After Elementor released Pro v3.3.8 on 08/23, and Elementor v3.4.3 08/29, I updated all other plugins on staging site. Updated Woocommerce Database.  Updated Elementor Pro to v3.3.8, then Elementor to v3.4.3.  After updating Elementor, ran Elementor database update.  Purged browser cache, flush optimizer cache, reload.  Good to go.

Also today, updated Pro to v3.4.0.  All responsive img srcsets still intact.  Hope others confirm and are also seeing that this is fixed.

and, in response to d…

Yes, I’m currently using ACF image fields for hero imgs on product archive pages as an alternative to using featured img (which I couldn’t do really easily for product categories).

I had previously set this up using Croco’s JetEngine metaboxes for a taxonomy term.  It worked, but had a few issues with data-srcsets while they were sorting out the WP5.8 updates - which i think they’ve also fixed.  I still use JetEngine for product archive’s and search templates b/c it gave a little more control than using a product archive grid/list widget.

Huge shout out to the Elementor team and everyone else involved. 

Thank You All

 

quick update & great news:  responsive img srcset issue fixed

After Elementor released Pro v3.3.8 on 08/23, and Elementor v3.4.3 08/29, I updated all other plugins on staging site. Updated Woocommerce Database.  Updated Elementor Pro to v3.3.8, then Elementor to v3.4.3.  After updating Elementor, ran Elementor database update.  Purged browser cache, flush optimizer cache, reload.  Good to go.

Also today, updated Pro to v3.4.0.  All responsive img srcsets still intact.  Hope others confirm and are also seeing that this is fixed.

and, in response to d…

Yes, I’m currently using ACF image fields for hero imgs on product archive pages as an alternative to using featured img (which I couldn’t do really easily for product categories).

I had previously set this up using Croco’s JetEngine metaboxes for a taxonomy term.  It worked, but had a few issues with data-srcsets while they were sorting out the WP5.8 updates - which i think they’ve also fixed.  I still use JetEngine for product archive’s and search templates b/c it gave a little more control than using a product archive grid/list widget.

Huge shout out to the Elementor team and everyone else involved. 

Thank You All

 

 

I tried with 3.4.7 and it’s still bugging, i don’t really know why.

You can have a look at my site at: https://phukiendienthoaigiare.com/

 

element made by elementor all are missing srcset

 

Original logo

 

Original post

 

Reply