Why is customer support so slow? Anyone else finding this?

  • 20 July 2021
  • 8 replies
  • 90 views

Badge

I posted a support request regarding an error on elementor meaning I can’t edit part of my site on 13th July.  I have received slow responses but at least I was getting a response.  I have now not had any replied to my emails for 4 days now and it has now got to the point where I can’t edit with elementor at all.  Is anyone else having issues with getting support with issues?  This is not the level of customer service I have come to expect from elementor.  I know there’s a pandemic but… 4 days for a response???  


8 replies

Userlevel 1

Okay Elementor Powers That Be. Listen up!

Badge

To be fair, I actually think Elementor is a fantastic editor.  I used DIVI before and was forced to move to Elementor because it was compatible with my theme.  I didn’t like it to start with because it was more difficult to learn than DIVI but now I’ve learnt how to use it properly, I wouldn’t switch back. It has some AMAZING features that I just couldn’t live without… WHEN it works well.  Which it does most of the time but… when it doesn’t I need support, AT LEAST within 24 hours, preferably much sooner and I don’t think is asking too much!  Right now, I’m not too happy that I’m stuck with Elementor because of my theme (which I definitely can’t change).  If the customer support were ok that’d be fine but it’s nigh on impossible to run a business with such slow support.

Userlevel 1

I created a new page with WP Block editor with the same content, layout, bells and whistles in less than an hour.  I have edited to my satisfaction several times.  I fixed the menu to go to the newly created page. It is very  basic since I was experimenting.  If you want to check, go to my WP site and click on In Between on the menu.

I am not going to give up but will not be using Elementor for a while.  I am going to webinars and reading and watching videos in Getttin Help.  It should not be this much of a learning curve. 

Elementor --- maybe hiring more support consultants would keep business?

Userlevel 1

Exactly.  I think for now I will put Elementor  on pause until they have as good support as WP.  When I am working I need help then -or at least in the next few hours.   WP is great with quick response. It is frustrating because I created a new page with Elementor and linked to it in my blog (already existing and built with WP).  Now I can not get to it to edit and it has major display issues plus I need to edit text.  WP editor gives me errors since it was built with Elementor.  I am done for now.

Badge

@Steph C They respond by email...eventually.  It took me a couple of days to get a first response, I answered immediately and then another 2 or 3 days wait to get a second response. Then 4 days. That’s really not helpful when you’re trying to run a business and there’s a bug with Elementor (eventually they responded and told me it was their issue) preventing your site from working properly! In the end I had to put a review on Wordpress and also on Trust Pilot to get a response from them.  You really shouldn’t have to go to these lengths to get a response, but...

Userlevel 1

I have the same question. Plus, how do they respond?  Email??

Badge

Sure,  thank you so much for stepping in.

So, I added a form and saved it as a global form along with a couple of other text widgets that I also saved as global.  I then used these global elements on 2 other pages.

I then found that if I went to edit the mobile view, when I returned to the desktop view, I was unable to click on the column for these elements in the navigator nor was I able to edit the global elements.  I therefore raised a support ticket.

After playing around a little (while waiting for a response) I realised that if I copied the whole section and deleted the old one I was able to edit the column and elements again but that every time I went to edit mobile view, the issue returned

However, now it seems that I am completely unable to edit any pages that contain these global elements (all other pages are fine).  Yesterday it was offering me the option of switching to safe mode but this did not work either.  I checked through elementor documentation and as suggested and asked my host to check / make amendments as per this guidance https://elementor.com/help/requirements/

No change.  But today it does not even offer me safe mode and just times out on these few pages that contain the global elements.  

Any help, in leiu of elementor support, would be very much appreciated.

Thank you

Userlevel 4
Badge +3

I posted a support request regarding an error on elementor meaning I can’t edit part of my site on 13th July.  I have received slow responses but at least I was getting a response.  I have now not had any replied to my emails for 4 days now and it has now got to the point where I can’t edit with elementor at all.  Is anyone else having issues with getting support with issues?  This is not the level of customer service I have come to expect from elementor.  I know there’s a pandemic but… 4 days for a response???  

Can you share what is the issue here and maybe one of the members might be able to help? 

Reply