Solved

Slider Content Entrance Animation Not Working

  • 6 December 2021
  • 8 replies
  • 379 views

Badge

 I would like to know if anyone is experiencing this: slider content (title, text, button) entrance animation is not working. It works in the editor, but not in the frontend.

To rule out, any conflicts, I made a fresh wp install with nothing but Elementor and Pro only. Built a single page with just the slider in it.

fade in UP captured in editor​​​​
frontend static content with no animation

 

icon

Best answer by Nico Abais 6 December 2021, 07:12

View original

8 replies

Badge

Found an article in reddit: if you rollback Elementor pro to v3.4.X, slides content animation works again

So, I installed v3.4.1 and can confirm that the animation indeed is working again in the front end. Any version with v3.5.X is not working.

This is a temporary fix!

Badge

Same problem for me for a month…

But I  need latest version for woocommerce customisation.

 

Please fix ...

Userlevel 2
Badge +3

Same issue with all “entrance animations” on latest versions of Ele and Pro…. they broken’s! :(

Rolled back to 3.4.8 and 3.4.1 respectively and still no joy.

Oh joy!

Badge

Why is this issue marked as solved ?

Can someone change it or nobody will take care of it ...

Same issue !! Please fix

I  have this issue also, not only the slider animations but a lot of entrance animotions… Please fix it.

 

---- EDIT ----

I have tried 4 or 5 different ways of adding the missing classes “animated” & “fadeInDown” to the “swiper-slide-contents” container with JS and jQuery.
The best and shortest version I tried was a jQuery snippet:

jQuery(document).ready(function($){
$("[class*=swiper-slide-contents]").attr("class","swiper-slide-contents animated fadeInDown");
});

That worked like a charm……. but for the first slide only  : ( 
The other 5 slides didn't take, or were reverted after the jQuery function had run on  pageload. And that first slide animation was terrible too because it loads with the title and text static and then quickly removes it to slide it in downwards. Too late and a dollar short, as the Americans say.
 

I also tried things that may have worked for others, like disabling some of the ‘experiments'. But even turning them all off didn't help, the animations remaind static. Also, other animations are frelled by this problem: some popups have a reversed entrance  animation, some popups have just given up and dissapeared completely from the frontend.

And now I also discoverd errors from the video widget (in the wp debog logfile) - which generates 11 identical erros every page-save:  

PHP Notice:  Trying to access array offset on value of type null in /home/…. /public_html/wp/wp-content/plugins/elementor/includes/widgets/video.php on line 1150

That's costing me about 1½ minute extra delay while saving a page,  So I'm kinda done for today and will bravely shorten the time a php script can run, and revert back to Elementor version 3.4.2, even thouth that will NOT fix all problems because what is written into the database will not revert when downgrading Elementor,. Grmpf.

---- End Edit ----

Same issue... !

Same issue, have to use JetEngine slider instead :\

Reply