Solved

Share buttons do not work when used for blogposts


Userlevel 1
Badge

Hi All, Have you had experience with share buttons not working? They look nice, but are completely useless on my blog posts. I use the Hello theme and I have a template for the blog post created. I tried to see how this would work on a regular page. It looks that when the buttons are on the regular page they do work. I put buttons to the draft page not published jet. I went to the “View” and when the view opened I clicked a button after button (FB, Twitter, Linkedin). Each click generated pop up for sharing. Nothing like that is happening on my published blogposts. Please let me know if you had similar experience and/or maybe you know how to fix this? 

icon

Best answer by Hélène Desaulniers 13 August 2021, 23:43

Inspecting your page, looks like you are using an icon list widget on your page and not the share button widget! Icon lists support links but it’s not ideal (although I notice your icons don’t have links on them at all).

Try using the share button widget instead.

View original

15 replies

Userlevel 4
Badge +2

I think Drafts URL cannot be shared so it could be why. Have you tried the buttons on a published post?

Userlevel 6
Badge +4

@JacekZ did you find your answer here? If so, please consider clicking “Best answer” to help out others. If you found it elsewhere, please share it here so we can mark your answer as the best one.

Userlevel 1
Badge

I think Drafts URL cannot be shared so it could be why. Have you tried the buttons on a published post?

Hi Helene, Thank you for writing. What do you mean by Draft URL? These buttons are on published posts. Well, this may be a little more complicated. They are on the template for the posts. So they are located on the aditional column that is the same for all posts. There are contact form there and links to categories and to the archive. Frankly, I am close to giving up and just removing these buttons from the template. 

Userlevel 4
Badge +2

@JacekZ You mentioned that your posts were drafts in your original post; the URL for draft posts is different than the URL for published post and I’m thinking this might mess up with your button URL.

However from what you say it doesn’t work on published posts either so that’s not the issue. 

Do you have a link to where your buttons might be? I’m sure I can fix it.

Userlevel 6
Badge +2

As long as it’s published then it should appear.

Go to the Post and check that it’s not set to Draft.

Userlevel 1
Badge

@JacekZ You mentioned that your posts were drafts in your original post; the URL for draft posts is different than the URL for published post and I’m thinking this might mess up with your button URL.

However from what you say it doesn’t work on published posts either so that’s not the issue. 

Do you have a link to where your buttons might be? I’m sure I can fix it.

Hi Helene, thanks for keeping up with the topic. Yes, I tried playing with this by creating “draft” of the page and using the same widget (I have it saved as a template). I did it to try how the widget would work on a page. Let me stress “on a page” - not on a post. And when the widget was used on the page it worked! I did not try to use it in the body (or content) of the post. Maybe this will also work. The widget does not work where it is now. It is “on side” of each post. Sorry I do not have the precise language. Let me try to explain. Each post on this blog is formated in the same way. In the left column you see the content of the post. In the right column you see links to archive, categories, message form and …. these buttons to share on the social media. When the widget is there it does not work. 

Here is the sample:

https://dreamtalepuppets.com/building-tabletop-puppet-second-session/

but the problem is on each blog post.

Userlevel 1
Badge

As long s it’s published then it should appear.

Go to the Post and check it’s not Draft.

Hi Imran, thanks for the comment. I am afraid my English is not too clear :)

 

Userlevel 6
Badge +2

As long s it’s published then it should appear.

Go to the Post and check it’s not Draft.

Hi Imran, thanks for the comment. I am afraid my English is not too clear :)

 

Apologies, I was rushing that as I typed.

Don’t worry, I’m a native English speaker.

Userlevel 6
Badge +2

Can you add a Screenshot (in Edit Mode) of the Social Share Widget, so we can see the settings, or record a quick video of the settings?

PS - have you any optimisation plugins activated?

Deactivate them, purge, and try again.

Userlevel 4
Badge +2

Inspecting your page, looks like you are using an icon list widget on your page and not the share button widget! Icon lists support links but it’s not ideal (although I notice your icons don’t have links on them at all).

Try using the share button widget instead.

Userlevel 6
Badge +2

PPS - I inspected your page, and the URL is missing on those links.
So just need to check that you are using the right Element.

 

It states Icon List - and you haven’t added the URL.

It’s not the Social Share that you think, or that’s how it seems on Inspection.

Userlevel 6
Badge +2

There you go - @Hélène Desaulniers  saw the same thing as me.

Userlevel 1
Badge

Helene and Imran,

You are my heroes! Thank you so much for giving this your attention. Of course! Extremly funny thing is that my brain is “remembering” something I am not sure now I did! I do not work on this website every day. I set the template for posts months ago and now I am afraid I am partly imagining what I did. So it looks that it is very probable that I am imaginig I used “share” widget but I used “icons list”. But this is more puzzling. It looks that again I am imagining that I did what I described earlier. Now the icons do not have even links provided!!! Sometimes I suspect that Elementor’s updates are plying this kind of tricks. Well sometimes they do. But the bottom line is that I am grateful for your help. I know what to do now! Thanks a lot!

 

Userlevel 1
Badge

@JacekZ did you find your answer here? If so, please consider clicking “Best answer” to help out others. If you found it elsewhere, please share it here so we can mark your answer as the best one.

Hi Susan,

Where should I find this “Best answer” to click?

 

Userlevel 6
Badge +4

@JacekZ It looks like it’s already been done which is why you can’t see it now but for future reference, it’s at the bottom of each post (in a question thread, not a conversation thread) in the same line as ‘like’ and ‘quote’.

Reply