Question

Editing a condition for my header

  • 8 September 2021
  • 14 replies
  • 91 views

Userlevel 1
Badge

Hello!

 

I’ve looked at several tutorials / videos etc. but I am probably asking the wrong question.

I’d like to edit a condition for my header. At the moment my header only displays on the Home Page but I want it on all of my pages. 

I believe that means I should edit the condition but the problem is, I cannot find the ‘edit condition’ facility. When I press ‘Update’ (because publish no longer appears), I have the option to either ‘up-date’ or go to ‘draft’. I do not have an ‘edit condition’ option. 

Can anyone help?

Thankyou

Marlene.

 


14 replies

Userlevel 7
Badge +4

When you edit your header template, do you see this option?

 

Userlevel 3
Badge +1

Hi, Marlene!

Here’s how you edit an already existing header:

  1. Open in Elementor editor
  2. Click the hamburger icon in top left corner to reveal Elementor menus
  3. Click Theme Builder
  4. Under Site Parts, click Header
  5. Find the header you want on the right (might be a list of headers if you’ve made several so find the one you want)
  6. At the bottom left, you’ll see “Edit Conditions” click to edit; it will open the conditions and you can change as needed

And that’s it!

Hope this helps!

Userlevel 1
Badge

Thanks, Julie,

This is what I asked for though unfortunately, it did not work. 

I’ve have the condition set for ‘entire site’ for my header but the header does not display on other pages. Have I misunderstood what condition is supposed to do, or do I need to do something else as well?

 

Marlene

Userlevel 3
Badge +1

Double check that you have “Include” selected and not “Exclude” from entire site.

Is your theme’s header being displayed instead? Also, check your page setting (the :gear: icon at bottom left the Elementor editor in a page). What is Page Layout set to?

Userlevel 1
Badge

Julie,

Your questions are so valuable, thankyou.

I go from page editor for Home Page, to Theme Builder, to Default header (the one with a small green light attached to it, top of the list). But there is a red line around this header with a warning underneath stating, ‘Elementor recognized that you have set this location for other templates: Default Header’  but I don’t know how to respond to it. 

Yes, it is definitely set to ‘Include’.

Is your theme’s header being displayed instead? - I don’t know?

I’ve checked my page settings and the page layout is set to ‘Default’?

Marlene

 

 

 

Userlevel 6
Badge +3

 

Userlevel 1
Badge

Thanks James,

I did go there but I don’t appear to have that tab ‘Theme Support‘.

Marlene

Userlevel 1
Badge

Hello Abner,

No, I don’t have that tab ‘Display Conditions’

Marlene

Userlevel 6
Badge +3

can you provide me more info just send you msg, I will require to see and check

 

Userlevel 7
Badge +4

@Marlene Ellis did you find your answer here? If so, please consider clicking “Best answer” to help out others. If you found it elsewhere, please share it here so we can mark your answer as the best one, thanks.

Userlevel 1
Badge

Hi Susan,

Unfortunately, I haven't solved the problem yet but will definitely share when I do. 

Marlene 

Userlevel 6
Badge +3

Give me some time dinving in it now

 

Userlevel 6
Badge +3

Can you please do something link this

If I have create a page James-test-pge, create a header and when i save if I add above condition then
the new menu will only be visible on this test page and rest of them will not be affected. Can you please reply me.

Userlevel 1
Badge

James,

 

I’m sorry for such a late reply. I couldn’t go to the computer last night. I’ll look for the header now. 

Reply