Question

Woocommerce Product Archives images are HUGE


Userlevel 1

All of a sudden my woocommerce category pages using the woocommerce product archive widget are no longer showing columns on desktop. Instead I am getting HUGE photos and everything is in a single column.

The settings are the same as they were yesterday and show that there should be 4 columns. 
After noticing the problem, I updated Elementor to the newest version assuming it would fix the problem or provide a setting to adjust it, but it has not. 

Any suggestions?
In the mean time I have had to revert to the standard archive pages for my theme rather than the ones I built in the theme builder using Elementor Pro.


29 replies

Same issue!
This happens after the update.

Same here… Does anyone know how to fix it?

I’m having the issue as well.  At WP > Customize > WooCommerce > Product Catalogue, I have Products per row set to 4 but recent (today) updates is messing things up on front end where it shows as 1 product per row.  Anyone w/ a fix?

Same here Ihope they fix it soon.  I was hoping to go live!

My categories and product images css are all wrong as well with the new update.

Same here.

I can’t even figure out how to fix this with CSS. Can someone take a look at this page and see if they can make the products lay out in 4 columns with CSS?

Here’s the page … https://cascaderivergear.com/product-category/frames/

Same here, I tried installing the WP Rollback plugin to rollback the plugin version but it doesn’t even allow it for the Elementor Pro plugin. Could you please fix it fast, Elementor? Needing this fixed urgently. Note to self: never update a plugin on a live site again.

Same here, huge problem, and I did it on live site thinking it was a small update after reading the release notes. ugh !!!  please fix!

Hello Peeps. . . I just messaged support and got a ticket opened for my 2 sites that are having this same issue, I’d suggest you do the same. . .FYI

 

Userlevel 3

I posted in bug fix. I have a temp solution to fix your sites see my post

 

I posted in bug fix. I have a temp solution to fix your sites see my post

 

Thank you! It works. Hope they fix it ASAP

I posted in bug fix. I have a temp solution to fix your sites see my post

 

Thank you! It works. Hope they fix it ASAP

Thank you for the quick fix!

I posted in bug fix. I have a temp solution to fix your sites see my post

 

Yes this worked!! Thank you Mario. I spent 6 hours yesterday de-activating and re-activating every plugin to see what was causing this conflict and Nothing worked… I sent a support ticket to Elementor as well, no response so far.  Mario, Will this CSS, in site settings, mess with anything else in a negative way or when they fix this issue? 

Best way to avoid this bug is actually to downgrade your Elementor pro version to v 3.3.0 via the admin menu.

Badge

Same problem on 2of our sites, for weeks now...

Badge

Another update today, not solved...

I posted in bug fix. I have a temp solution to fix your sites see my post

 

Yes this worked!! Thank you Mario. I spent 6 hours yesterday de-activating and re-activating every plugin to see what was causing this conflict and Nothing worked… I sent a support ticket to Elementor as well, no response so far.  Mario, Will this CSS, in site settings, mess with anything else in a negative way or when they fix this issue? 

Not forking for me :( Please help

Badge

This seems to be fixed in the latest update!

Badge

We are having the same issue. We had to update to WooCommerce version 5.7.0 because utilizing a vulnerable version. Elementor Pro also had an update and when updated to Version 3.4.1 it began displaying the images huge and on a single column opposed to five products per line. This only happens when I click on filtering options. Not when I go directly to the main product/archive page.

 

I have reverted back to Elementor Pro 3.3.2 for all websites except one. So a fix would be appreciated.

 

Just to be clear, the combination of Elementor Version 3.4.4 & Elementor Pro Version 3.4.1.

Userlevel 6
Badge +3

is it resolved ?

Having the same problem. Tried the fix from Mario Beach, but it didn’t work.  I have Elementor version 3.4.1. Any other fixes?

Userlevel 6
Badge +3

All of a sudden my woocommerce category pages using the woocommerce product archive widget are no longer showing columns on desktop. Instead I am getting HUGE photos and everything is in a single column.

The settings are the same as they were yesterday and show that there should be 4 columns. 
After noticing the problem, I updated Elementor to the newest version assuming it would fix the problem or provide a setting to adjust it, but it has not. 

Any suggestions?
In the mean time I have had to revert to the standard archive pages for my theme rather than the ones I built in the theme builder using Elementor Pro.

hi is that resolved or still looking for solution ?

This might help some that don’t want to see a long image box with all the coding for a band-aid.  Go to 

Customizing ▸ WooCommerceProduct Page.  Product Layout choose stacked…..that helped move my images to the left which covered up the issue with rows of images.

Got a better fix for this product page issue.  Just go to theme options | WooCommerce | Advantage | the Enable Default woocommerce Product Gallery

Reply