Question

Woocommerce Cart popup showing duplicate product images

  • 7 October 2021
  • 9 replies
  • 154 views

Badge

I am using Elementor Pro, WooCommerce, and Astra theme.

Menu pop up widget, when clicked on frontend, shows double image (instead of one) for each and every item in the cart.

Any solution for this?


9 replies

Userlevel 3
Badge +2

Noodlefly, can you give us a little more to go on?  When you go to checkout.  Is it showing multiple items?  Also are you using the standard Elementor pages, and not a third-party plugin?  Are you double clicking?
 

Not to be a jerk but have you done the basic step of turning off all plugins except WooCommerce and Elementor and turning them back on 1 by 1 to see if it’s a plugin causing it. 


Just a little more and maybe it’ll help us determine what’s wrong.

Badge

Thank you for your response.

Please see screenshot: Each item in the cart is showing 2 images instead of 1.

Apparently this is a common phenomenon:

https://wordpress.org/support/topic/double-picture-at-cart-preview/

Several codes that were suggested here all do not work properly.

 

 

 

Userlevel 3
Badge +2

Can you give me the URL so I can run it through the Firefox inspector?

Badge

https://sungs.sg-host.com/

 

Thank you

Userlevel 3
Badge +2

I see the problem.  The cart has one listing for the item with a link to it and another listing for the quantity and the price.

Are you using the Elementor menu cart?

Badge

Yes, using the Elementor menu cart widget. Is there a solution for this?

Also the dollar amount in Firefox browser is showing black, even though I have set it as white in Elementor. Works fine in Chrome. Any ideas?

Userlevel 3
Badge +2

You’ve reached the limit of my knowledge about this.  Sorry I couldn’t be more helpful.

Userlevel 7
Badge +4

@Francis Johannes did you find your answer here? If so, please consider clicking “Best answer” to help out others. If you found it elsewhere, please share it here so we can mark your answer as the best one, thanks :)

Badge

I fixed the same issue with the  following custom CSS. 

img.attachment-woocommerce_thumbnail.size-woocommerce_thumbnail:first-child { display: none!important; }

Reply