Question

Warning: Undefined array key "template"

  • 24 July 2021
  • 5 replies
  • 317 views

Badge


Warning: Undefined array key "template" in C:\xampp\htdocs\Itautoban\wp-content\plugins\ultimate-elementor\admin\bsf-core\index.php on line 327

 

Creating a mentor account in a WordPress desktop gives the same error message
Connecting blocks to the library and inserting them in the section gives the same error

 

What can you do to help solve this problem?!

 

Thank you in advance


5 replies

Userlevel 2
Badge +1

It seems that ultimate addons for elementor is looking for a theme that does not exist. I would suggest that you move the folder ultimate-elementor from your plugins folder to a new folder names removed-plugins. Create that removed-plugins folder in the same wp-content folder, the same place that you will find the plugins folder.

Then login to your site. You will see an error regarding the plugin being removed so acknowledge the error and let wordpress do what it does. Then install the ultimate addons for Elementor again. See if that works. If it does solve the issue, just delete the removed-plugins folder from your local directory.

Else you could just deactivate and delete your current version of the plugin (not an issue if you have not used it extensively) and then reinstall a fresh version of the plugin. 

 
 
×
 
 
 
Badge

Thank you for your help.
I did all the steps but the problem still remains and has not been resolved.

Userlevel 6
Badge +4

@Mehran Eshghi did you find your answer here? If so, please consider clicking “Best answer” to help out others. If you found it elsewhere, please share it here so we can mark your answer as the best one.

Badge

@Susan Hope Unfortunately, I have not yet found a way to solve this problem, but if I get the right result, I will definitely share it here.

Thank you @Steve Kinzey 

Userlevel 2
Badge +1

@Mehran Eshghi how about trying the following steps:

  • Backup your site
  • Upgrade your PHP version to a higher version of 7 than what you are using, perhaps even PHP 8
  • If the updated PHP causes a problem, which can happen, downgrade to the version below (eg PHP 8 to PHP 7.4 or PHP 7.4 to 7.3).
  • Increase the maximum execution time in XAMPP (I think you are using XAMPP as your localhost)
    • Navigate to the XAMPP directory 
    • Open php folder
    • Open the php.ini file in your text editor (Visual Studio Code, Sublime, Notepad, etc.)
    • Using CTRL+F find the line max_execution_time
    • Edit that line so it reads: max_execution_time=300
    • Save the php.ini file 
  • Check again that all your plugins are up-to-date
  • Then make sure that all your plugins are compatible with WP 5.8.1 (the latest version of Wordpress). 
  • Verify that it is not due to a plugin conflict by deactivating all your plugins besides Elementor, Elementor Pro, and Ultimate Elementor. If this solves the issue, reactivate them one by one to find the culprit
    • If you end up finding a conflict you will then need to adjust your site to account for whatever the conflicting plugin was providing

Lastly, please reply after trying this suggestion and  let me know if it worked or not. Thank you.

 
 
×
 
 
 

Reply