Trouble accessing kit templates

Hello. i just installed Elementor Pro this morning.  I tried to open up one of the kit templates, and I got the following error message:


Something went wrong.

Nothing to worry about, just try again. If the problem continues, head over to the Help Center.


Can someone tell me what I’m doing wrong?


10 replies

I have the same problem also, I have suggested to them to have a folder that we can access with all the templates, we then can download the template of our choice


Userlevel 1

Looks like to me that they are ignoring us as I have not heard anything. I got the templates to load because the gzip was not activated on my server (cPanel → PHP Version → Options scroll down and tick the zip option)

However even though the templates loaded and created a 2nd set of pages the elements/widgets did not load. Doncha just love it? 


Same issue here.

When I install a kit none of the templates load. :(


Userlevel 1

So any update on this crazy template kits? I put in a ticket 3 weeks ago and of course no response

Still waiting for a solution to my problem.  I can’t seem to make a page from scratch either, so I’m beginning to think I paid %50 for a useless program.  Can someone who works for the company contact me, please?

Thanks for responding!

but I

I literally just added this subdomain on Wednesday, and loaded WordPress onto it.  I had an older version of Elementor on the primary site. but I never used it.  I updated it, and saw the kit templates.  I thought it would be good for me to try one out, as I’m a total novice at this stull and I have never had much success with drop-and-drag programs.  (Twenty years ago, I used to code sites by hand, but that was when HTML 1 was still in use.  Anyone remember Front Page?}

Anyway, I found a template I liked and tried to apply it,, only to get the error message I reported earlier.  In response to my first helper, I did find that there was a new update on Elementor (already), and installed it.  I emptied out my WordPress cache.  If there’s any other cache that I should be emptying, I don’t know where it is and would appreciate some advice on that.  Memory is fine.  I have no idea how to check or improve my internet speed. 

Any further help would be appreciated.

Userlevel 6
Badge +2

did you update something some plugins or WordPress version got updated ?
did  you get cache cleaned for server too
did  you get memory checked, like running low
did you get your internet speed working good 

Thanks, I found the update and cleared out my cache.  But I still got the same error message.

Have a great day1

Userlevel 6
Badge +1

I had a similar issue yesterday; it disappeared after I updated to EP 3.3.4 and cleared my cache. See if that works for you (if you haven’t already done that).

Userlevel 7
Badge +4

You’re not doing anything wrong, this is a new feature and it’s still buggy it seems.  You can follow this issue in github, hopefully the Elementor team fixes this soon: