Question

Too Many Requests / Elementor Library: Not connected (HTTP Error (429))

  • 27 November 2021
  • 19 replies
  • 358 views

Hello all, 

I have the challenge of not being able to connect my Elementor. Whenever I click on Connect Account, I get a page that says “Too Many Requests”.
For this reason, the Elementor library is also not connected (Not connected (HTTP Error (429))).

I have now deleted and reinstalled the wordpress several times. (with completely new database)
Disabled all plugins but the error does not go away. 

Also my hoster (Hostinger) could not help me. 🙁
I do not have a Pro but would like to use the free templates of the library. 

Can anyone help me? ;-(


19 replies

Badge

I have the same issue :-( Let me know if you find a solution.

Badge

Message from support:

 

I'm sorry to hear that you're having trouble activating your Elementor Pro license.

This error happens when the request is blocked by some firewall or restriction of your server.
In this case, you have to contact your Hosting Company so that they can give the green light to Elementor.

Please ensure that your WordPress setup/server meets the minimum Requirements for Elementor, especially a Memory Limit of 512M.

To troubleshoot this issue, follow these instructions:
1. If you are using security plugins such as WordFence or Securi, try temporarily deactivating it or activate the learning mode of this plugin.
https://www.wordfence.com/help/firewall/learning-mode/
2. This issue can also be due to the firewall of your server. Ask your hosting company to disable any firewall or ModSecurity and check if it helps.

In the meantime, do let your hosting provider know that Elementor plugins need to connect to the servers are at, just to confirm there are no firewall settings preventing this connection:
elementor.com
my.elementor.com

 

Badge

I also have Hostinger by the way… Currently waiting for them to look into it. 

Badge

same problem here 

dont know how to fix it 

elementor told me to find hostinger

hosinger told me to find elementor

LOL

Badge

@Wanglee Wanglee when did you speak to them? When I spoke to them yesterday they seemed to be aware it was an issue affecting several users, and that they would work with Elementor to fix it.

 

 

Badge

I have just confirmed with them again that they are working on the issue. So I think we just need to wait for Hostinger. Perhaps you spoke to them at a time when they were not aware it is an issue on their side - or perhaps that particular person was not informed. But I had several people from support confirm now that they are aware of it and investigating.

Same problem here, also using hostinger

I think it has been resolved, mine is working well now

Badge

I think it has been resolved, mine is working well now

I successfully connected a few days ago, but automatically disconnected a few days later

dont know why

Badge

@Wanglee Wanglee when did you speak to them? When I spoke to them yesterday they seemed to be aware it was an issue affecting several users, and that they would work with Elementor to fix it.

 

 

I also communicated with them yesterday and told me that this is a multi-user problem that needs some time to be solved. At present, there is no solution yet

Same problem, hostinger as well.

Badge

Hi,

We are with the same issue with hostinger.

Too many requests trying to connect to elementor for the pro version.

Badge

For me it works again today (after a few days without working).

Badge

Also works for me again. But using the incognito mode to activate it.

 

Badge

According to Hostinger the issue was on Elementor’s side, and they have fixed it now. The story does not tell why only Hostinger users seemed to have been affected, but maybe Elementor can answer that :-) 

Badge

good news! It has been resolved, mine can be used normally, the hostinger told me that

“Hello! Too may requests error was caused by Elementor infrastructure failure, more precisely, my.elementor.com website outage, which we can see now was fixed from their side, so you should be able to activate it“

Reply in our Messenger

 

and i try to contect and it worked hope you all can sovle it right away

Hostinger support replied, that the problem was in Elementor infrastructure and should be resolved. Too many requests has changed to “An error occurred. Please check your internet connection and try again. If the problem persists, contact our support. ()”
Does anybody see similar error?

Badge

hello everyone
There is a bad news. A few days after the successful link, my elementor Pro version automatically disconnected again, and the phenomenon of too many request appeared again.
Fortunately, my website has been completed. I hope you don't have this situation. I hope this problem can be solved as soon as possible

same problem here 

dont know how to fix it  elementor told me to find hostinger

hosinger told me to find elementor

LOL

:laughing: same happening to me today.

you got any working solution?

Reply