Solved

"Product Related" widget 1 column stopped working


Userlevel 1

Anyone else noticed that the 1 column setting for Woocommerce Product Related widget have stopped working? I know this might be an exotic setting, but for our template it’s essential. The 1 column used to work great, now it’s a 2 column minimum and look like garbage across our site.

 

icon

Best answer by Danny Foo 9 August 2021, 16:51

Still an issue on 3.3.5

There’s a temporary fix for this here; https://github.com/elementor/elementor/issues/15773#issuecomment-891200592

You might want to use a code snippet plugin to enable / disable this part of the CSS when it’s finally fixed.

View original

20 replies

Yes.  It appears this is a bug.

Userlevel 7
Badge +4

This issue is on github, says update to pro 3.3.4 to fix.

https://github.com/elementor/elementor/issues/15718

It did not work for me

We are having the exact same issue. Has a solution been identified yet? We did upgrade to latest elementor pro version, but problem is still happening.

I am facing same issue but with slightly different behavior. After updating to 3.3.1,  Product Related element showing single column instead of 4.

 

Badge

I’m also having the same problem with Pro version 3.3.4. Instead of four columns, Related Products wiget is showing one column.

I am facing same issue but with slightly different behavior. After updating to 3.3.1,  Product Related element showing single column instead of 4.

 

I have the same problem » Product Related element showing single column instead of 4.

I have the same problem, after updating to 3.3.1,  Product Related element showing single column instead of 4.

I'm not convinced for the first time - updates are evil

Userlevel 7
Badge +4

Update 3.3.5 is out, fixes this bug:

https://github.com/elementor/elementor/issues/15773

Userlevel 7
Badge +4

Update 3.3.5 is out, fixes this bug:

https://github.com/elementor/elementor/issues/15773

Seems like 3.3.5 doesn’t not fix this issue after all, even though they said it would.  I’m hoping they will release another fix soon. :(

Userlevel 1

Update 3.3.5 is out, fixes this bug:

https://github.com/elementor/elementor/issues/15773

Bug still not fixed with this update unfortunately

I am facing same issue but with slightly different behavior. After updating to 3.3.1,  Product Related element showing single column instead of 4.

 

Same issue here. I’m on Elementor Pro Version 3.3.5 (with Elementor Version 3.3.1).

Userlevel 1

Hey guys. It might not be the most ideal fix because elementor should just handle it, however, if you want to force it back to one column until they patch it you can use some css:

@media (max-width: 480px) {
.elementor-element.elementor-products-grid ul.products {
    grid-template-columns: repeat(1,1fr);
}
}

If you have elementor pro, use it on your product template/page, or can use it in appearance > customize > additional css.

 

Hello,

Sorry this css don’t work with me, i have this error message :

unknown property ‘grid-template-columns’ . Expected RBRACE at line 3, col 37.

I’m also with Elementor pro 3.3.5 and product related show actually a single large column instead of 4 or 6.

Same problem after I updated Elementor and Elementor Pro. When will we get a fix?

Having a similar issue, with the Product Categories widget.

It will only show one column of categories, no matter what changes I seem to make.

The “Products” widget seems to work fine, as before. Issue arose when updating versions (3.3.5)

Woo Commerce Version (5.5.2)

Still an issue 3.3.5 so it appears that it hasn’t been fixed since it first occurred in 3.3.3. 

Any news of an update? 

Badge

Still an issue on 3.3.5

There’s a temporary fix for this here; https://github.com/elementor/elementor/issues/15773#issuecomment-891200592

You might want to use a code snippet plugin to enable / disable this part of the CSS when it’s finally fixed.

Tank You Danny Foo…. your shared fix worked for me

Reply