Sticky

Having Problems Using Elementor? Start Here!

  • 18 April 2021
  • 8 replies
  • 601 views
Having Problems Using Elementor? Start Here!
Userlevel 7
Badge +6

Latest version: http://elemn.to/fix

 

If you are experiencing problems using Elementor, please try to follow these steps:

  1. Read our documentation and check our FAQ. Make sure your server’s PHP version is above 5.4, although above 7.0 is ideal.
  2. Make sure you are using the most updated versions of Elementor, WordPress & your theme.
  3. Deactivate all your plugins besides Elementor (and Elementor Pro). If this solves the problem, gradually activate your plugins one by one, until you spot the problematic plugin.
  4. If you have a caching plugin, make sure you deactivate it, or even better – purge the cache.
  5. Change your WordPress theme (temporarily) to WordPress Twenty Nineteen (or other default WordPress theme).
  6. On your WordPress root folder, edit the wp-config.php and set the value of WP-DEBUG to true.
  7. Ask in the Elementors community Facebook group & forum
  8. Under Elementor > Settings > Advanced switch editor loader method on
  9. If you cannot load Elementor, see this guide

If you have followed all these steps and you’re still encountering difficulties, please contact support following these steps:

  1. Describe the issue and what led to it. Please be as accurate and detailed as possible.
  2. If you suspect the issue was caused by the theme or plugin you are using, please attach the name + URL of the theme/plugin.
  3. Send us your system info. You can find it in under Elementor → System info. Please use Pastebin to paste it and send it to us.
  4. On the Elementor page, Press F12 and select the console tab. Paste the messages in Pastebin.

 


8 replies

Userlevel 6
Badge +3

Thank You @Verdi Heinz  for suggests.
I’m curious to know why you suggest twenty-ninetee and twenty-twentyone theme? 

Userlevel 3
Badge +1

Thank You @Verdi Heinz  for suggests.
I’m curious to know why you suggest twenty-ninetee and twenty-twentyone theme? 

Hey @Barretta how are you? I think it is because those are the “Default WordPress Theme” and most of the time there is any compatibility issues. If you always try to “debug” or find an issue just follow those steps. Something to add to Verdi’s post is that sometimes you also need to go to Settings > Permalink > and Save the changes. That solve a lot of issues as well.

Userlevel 6
Badge +3

Thank You @Verdi Heinz  for suggests.
I’m curious to know why you suggest twenty-ninetee and twenty-twentyone theme? 

Hey @Barretta how are you? I think it is because those are the “Default WordPress Theme” 

Oh yes is correct but i’m curious about the choice of 2019 (OLD) and not the 2021 (NEW) default wordpress theme

Userlevel 4
Badge

Thank You @Verdi Heinz  for suggests.
I’m curious to know why you suggest twenty-ninetee and twenty-twentyone theme? 

Hey @Barretta how are you? I think it is because those are the “Default WordPress Theme” 

Oh yes is correct but i’m curious about the choice of 2019 (OLD) and not the 2021 (NEW) default wordpress theme


He may have copied and pasted an old post, lol :joy:

Userlevel 6
Badge +3

Thank You @Verdi Heinz  for suggests.
I’m curious to know why you suggest twenty-ninetee and twenty-twentyone theme? 

Hey @Barretta how are you? I think it is because those are the “Default WordPress Theme” 

Oh yes is correct but i’m curious about the choice of 2019 (OLD) and not the 2021 (NEW) default wordpress theme


He may have copied and pasted an old post, lol :joy:

LOL yes maybe i’ve not thought about this and i was trying to discover some reason to choose the old and not the new.
@Verdi Heinz it’s only that the reason? ;) 

Userlevel 7
Badge +6

Thank You @Verdi Heinz  for suggests.
I’m curious to know why you suggest twenty-ninetee and twenty-twentyone theme? 

Hey @Barretta how are you? I think it is because those are the “Default WordPress Theme” 

Oh yes is correct but i’m curious about the choice of 2019 (OLD) and not the 2021 (NEW) default wordpress theme


He may have copied and pasted an old post, lol :joy:

LOL yes maybe i’ve not thought about this and i was trying to discover some reason to choose the old and not the new.
@Verdi Heinz it’s only that the reason? ;) 

Actually the emphasis is on the word ‘temporary’. It’s simply to to do a test. Of course we recommend Elementor Hello Theme!

 

Userlevel 6
Badge +3

Thank You @Verdi Heinz 
I ever use https://elementor.com/hello-theme/ 

I’m not sure this is the right place to post this but, if not, please move it to the proper section. I posted this question in the Facebook group about a week ago and have not gotten a single answer yet. I thought I would repost it here to see if I can get some help.

I am at my wit's end, been trying to figure this out for 2 days now. I have 3 regular posts for which I created a Post Archive Template and a Single Post Template. I created a new page to display the Archive template and set it as my default post page in WP because Elementor would not let me edit the original blog/post page. The archive page works fine, but none of the 3 posts will display in my Single Post Page. Two of them display in a page that appears to be semi-styled, but I have no idea what template it is and I don't recall styling anything as plain as it is. One of the posts only displays in what appears to be a category template which I have also not created. Why won't my post display in the Single Post template that I created? Yes, I have properly set the conditions on both of the templates. This is the URL to the archive page which works correctly. Learning More about Web Design – HBB Website Solutions (hbbx2.com)

Reply