Question

From submissions keep loading


Userlevel 3
Badge +1

Hi all, 

for some reason some of my websites have a problem with the form submissions. 
On one site all works fine, on others the submissions are stuck at ‘loading’ so I can't see them.

Checked if the ‘experiment’ was set to active, cleared cache, disabled cache etc.
Same setup of plugins, same hosting setup. Any idea's?


29 replies

Userlevel 7
Badge +4

Can you provide a screenshot to check out?

Userlevel 3
Badge +1

Don't think it will do much good, but here's what I'm seeing. 
Kept it open for half an hour but it stays like this. 
I know submissions have come in, so that's not the issue either.

Like I said; other installs with exact same configurations seem to work as they should.
I've seen a few topics on the elementor community fb page but none of these has an answer, nor does the github issue I set up.
 

Userlevel 7
Badge +4

Do you see any errors in DevTools?  Maybe a plugin or host setting (like modsecurity) interfering with the AJAX request?  Are your other installs that work on the same host?

Userlevel 4
Badge

Hey, @Michael Maximus  👋 did you find your answer here? If so, please consider clicking “✔ Best answer” to help out others. If you found it elsewhere, please share it here so we can mark your answer as the best one.

Userlevel 3
Badge +1

Do you see any errors in DevTools?  Maybe a plugin or host setting (like modsecurity) interfering with the AJAX request?  Are your other installs that work on the same host?

On further inspection I was wrong on my original statement.
The websites where it doens't work are not hosted on my own host. 

Is this something I can fix from direct admin myself?

 

I checked the error and got:
“Failed to load resource: the server responded with a status of 405 (Method Not Allowed)”

In full:
JQMIGRATE: Migrate is installed, version 3.3.2
/wp-json/elementor/v1/form-submissions:1 Failed to load resource: the server responded with a status of 405 (Method Not Allowed)
common.min.js?ver=3.2.5:2 Objectcode: ""data: []message: ""__proto__: Object
consoleError @ common.min.js?ver=3.2.5:2
admin.php:1 Uncaught (in promise) Response
jquery-migrate.min.js?ver=3.3.2:2 JQMIGRATE: Migrate is installed, version 3.3.2


 

Userlevel 6
Badge +6

There is seven methods you can try in order to fix a 405 error on your WordPress site:

  • Check to ensure that you’ve entered the correct URL into the address bar.
  • Roll back any recent WordPress updates, to distinguish whether that’s causing the issue.
  • Uninstall any new plugins or themes one at a time.
  • Ensure that there haven’t been any unexpected database changes.
  • Confirm your server’s configuration.
  • Look through the server-side logs stored by WordPress.
  • Attempt to debug your application code or scripts.

In this scenario, the best thing you can do is often to contact your hosting provider and report the problem. 

Userlevel 7
Badge +4

Hey, @Michael Maximus  👋 did you find your answer here? If so, please consider clicking “✔ Best answer” to help out others. If you found it elsewhere, please share it here so we can mark your answer as the best one.

Userlevel 3
Badge +1

Hi Susan, no haven't fixed it. 
Happens to clients that are on their own hosting. Works fine on all websites where I take care of the hosting so left it as is. 

Badge

Hello everyone, same problem with my website. Elementor Team, what’s going on with You guys?

 

Badge

Same. here’s my screenshot for console.

 

Badge

Hi, any updates on this one?

Badge +1

Same here…. Same Loading … screen.
Anyone with a new update?  

Badge

Hi everyone,

Same problem here.
The page “Submissions” is stuck on loading.
I correctly receive the emails from the submissions, but cannot check the Submission page from elementor, due to this problem.


Is there any update on this? Any solution?

Badge

same here

Badge

Hey there... Same issue just detected here on one of my sites as well… email notice delivered, but nothing loading in Submissions. Same issue in console as Jen found:

Would like to know if anyone discovers what might be causing it. 

Badge

Same problem here… 

 

Badge

Any suggestions to solve it?

Badge

I have the same issue too ..

I have the same issue too ..

 

For me to...Does somebody have a solution…..???

Badge

Hi guys! I found this, have you tried?

7 Ways To Fix Elementor Stuck On Loading Screen Error

  1. Check For Plugin Conflicts. ... 
  2. Check Your PHP Version. ... 
  3. Change Editor Loading Method. ... 
  4. Use Properly Coded Elementor Plugins. ... 
  5. Check For Browser Addons. ... 
  6. Switch Off RocketLoader in Cloudflare. ... 
  7. Check If Your Theme Is The Issue.

Good luck! 

Badge

I have the same issue!

Having the same issue after moving a website to a different hosting. 

Hello!

 

I had the same problem and the images didn't appear in another admin interface before. At the suggestion of the system administrator, I turned off "HTTP Limit Methods Protection" in the CPANEL NGINX settings, which solved the image problem.

In the same way, I turned it off here on the WP page storage. The submission list is loaded.
 

 

Oops.

Reply