Question

Can't update or download to latest Elementor pro 3.3.3


Userlevel 1

Hi,

 

I can’t update to the newest Elementor Pro version (3.3.3). It gets me the following error: an Update Failed: Download failed. Unauthorized” 

 

Also, If I go to myelementor.com account Ican only download version 3.3.1 instead 3.3.3

 

I’ve followed the steps that appear in this article without sucess: https://elementor.com/help/error-when-updating-elementor-pro/#i-receive-this-error-update-failed-download-failed-unauthorized

 

I'd appreciate any help.

 

 

 

 


19 replies

Same Issue! Please advise

I encountered the same issue, although in my case it was showing version 3.3.4 of Pro. I contacted support and apparently 3.3.1 is the latest version but for some reason (unclear why) I’m seeing the release notes for versions past that and I have a notice to update to 3.3.4 in my Dashboard, but they said anything past 3.3.1 is still under development. Seems weird because if there was to be an update to 3.3.1 you’d expect it to be 3.3.2, not a sudden jump to 3.3.4 or whatever version number they go with, but I have the exact same problem when trying to update to 3.3.4.

 

Don’t know why we’re seeing newer versions if we can’t update to them/they aren’t actually released, but that’s what support said when I contacted them. Not saying it makes sense, just that this is the explanation I was given.

Userlevel 1

Hi @Roger That, thanks for your message. It’s certainly very strange to show updates that we can’t make.

 

My installation is now also showing version 3.3.4 Pro.

Yep, it’s definitely weird. Don’t understand it, especially since the change log clearly shows versions newer than 3.3.1 and people are posting on here about newer versions of the Pro plugin, and there are posts on github that specify installing versions newer than 3.3.1…. It’d be nice if whatever’s going on with this could get cleared up, either by actually releasing the versions that WP thinks we should be updating to, or by not having them visible in the normal release channel.

why say the release date of July 13th and then you cant even download 3.3 from our own account pages, yet you can go onto a GPL site and download elementor 3.3.4 for free… 

What is happening ?!

It sounds like something must’ve been misconfigured on Elementor’s end of things, based on what support wrote in an email:

 

That's correct, version 3.3.2 and 3.3.4 are not fully developed, it should be available for download in the next few days, usually, we recommend checking the Changelog for any new updates on the versions, however, it happened that the two latest versions listed there weren't released yet.

Our developers are currently working to prevent this from happening again, for now, I recommend you to check the Elementor account to see which version is available to download from there.

 

So maybe we’ll get a new release in a few days?

Userlevel 1

I have a different response from Elementor support:

 

Currently, we have a dependency between the Elementor & Elementor Pro versions.
Our latest versions are Elementor 3.3.1 & Elementor Pro 3.3.4. In order to upgrade to our latest versions, please make sure you update Elementor to the latest version before upgrading the Pro version.

In case you already have updated Elementor Pro to 3.3.x and didn’t update Elementor, follow these steps:
1. Rollback to the previous version of Elementor Pro
2. Update Elementor
3. Update Elementor Pro

 

I’ve followed the steps  but it’s still not working for me. I can’t update or download latest version of Elementor pro. I'm stuck in version 3.3.1

Update failed: Download failed. cURL error 56: OpenSSL SSL_read: Connection reset by peer, errno 104

 

i’ve tried all the suggestions as well.

I’m having the same issue: Update failed: Download failed. Unauthorized

Same problem. Wordpress Notify that there is an update to 3.3.5 but can’t download from elementor.com the 3.3.5. The download is elementor-pro-3.3.1.zip

Userlevel 1
Badge +1

Same issue here. Been going on for weeks if not longer. My license shows as active but I can’t update any sites (all get the “update failed, unauthorized” error) and when I try to download the latest version directly from the Elementor site, all I get is 3.3.1.

Same problem, can’t update from 3.3.1 to 3.3.5 elementor pro. Tried to reconnect. And from my account at elementor.com there is only 3.3.1 downloadable version.

Userlevel 1

I have disconnected - connected this site 10 times now. I give up :(

Stuck at this annoying update failed, unauthorized error. Like every one else, suggestion to upgrade to 3.3.5. but only 3.3.1. available for manual download.

Userlevel 1
Badge +1

Disconnecting/reconnecting does nothing for me, either.

I finally got a response from support. They instructed me to do a full site backup (of course), roll back to a previous version of Elementor Pro, then update Elementor, then updated Elementor Pro again. Or, alternatively, delete both plugins entirely, then reinstall Elementor, and finally Elementor Pro.

This seems like a hack solution at best, assuming it works at all. I may have time later today to test it on a smaller site, but frankly even if this does work, going through this process on all my sites seems ridiculous.

There’s clearly something going on with Elementor and their license activation system, and it has radically put a damper on my enthusiasm for building sites using it.

Problem solved

When you install and activate the latest Elementor free plugin, then for the PRO install v3.2.1 or v3.0.0 and activate the plugin, now go and try editing pages it should now work. The update elementor message then automatically disappears.Follow me for more info on how to solve issues  like this and also how to get purchase codes for nulled plugins too. We the Genius

Badge +1

I had been seeing the following message in a number of my sites:

 

Update failed: Download failed. cURL error 56: OpenSSL SSL_read: Connection reset by peer, errno 104

 

I have discovered that I fix the problem by:

 - deactivating the Pro version in the Plugins list

 - click to update the now-deactivated Pro version

 - click again to reactivate the Pro version (now at v3.4.1)

 

I had previously tried de-connecting the license (as I read in this article), but it did not work.

All good now, though it is confusing to me that the latest version of Pro is v3.4.1 but the free/basic plugin is at v3.4.4. 

Badge

Same issue please help

 

Badge +1

@Sadia Rai , did you try my suggestion?

 

I have discovered that I fix the problem by:

 - deactivating the Pro version in the Plugins list

 - click to update the now-deactivated Pro version

 - click again to reactivate the Pro version (now at v3.4.1)

 @Joseph Valenti - thanks for the great tip - it worked for me.

I haven’t seen any error messages, but the update option wasn’t showing up. Deactivating the Pro plugin fixed this immediately.

 

 

 

 

Reply