Solved

bug in gallery widget ios


Userlevel 1

Hey,

I found a bug on iOS. / iPhone 12 Max Gallery Widget, what appeared last week the first time.

Adding more than around 25 pictures will lead to an 404.

I have checked the Portfolio page and did not find any broken links. But I presume the issue may happen because of the Gallery widget that doesn't work correctly on iPhone X with Safari and iOS 11. It works with other models in Safari on iOS12 and greater.

If anyone knows a workaround until it will be updated that would be nice 👍

🐜:
https://imgur.com/a/caAawnB

Portfolio page example:

https://voges-design.com/portfolio/

 

icon

Best answer by Abner Rojas 15 June 2021, 00:49

View original

16 replies

Userlevel 1

Portfolio page now moved to:

https://voges-design.com/portfolio-overview/ 

for avoiding another Bug:

 

Q2:

when changing the slug to “portfolio” again this old code is being added by the old deactivated theme - any idea what causes that? It seems to be written in the classic editor, which is re-created after deletion.

https://voges-design.com/portfolio/

 

 

Userlevel 7
Badge +4

Images load fine for me on iOS14.6

 

Userlevel 1

Hi

 

thank you for your reply.

- at the moment it's working because I had to create a workaround, issue is not solved.

- desktop has around 140 photos, mobile now 32. 

the issue is still there sadly and need to be solved,  a Tablet version with only 32 photos is not acceptable sadly 😳 

- I can't use multiple image gallery on mobile, so I reduced the images to 32 pictures (for now) for mobile to a avoid that error and hide the “full Desktop gallery” on Tablet and mobile. 

 

- I sent elementor several messages but never got one answer, waiting over one week now sadly.  portfolio is the most important thing as photographer - that should work I think.
 

- Otherwise it's hard to recommend the builder to colleagues if it's not working with galleries. I thought the support would be better in terms of respond in such a case.

 

  • especially user can't solve that issue, so I would have appreciated help from support here / i think it's a Bug that is very important to solve especially when using "multiple gallery" in one single gallery.  Otherwise that widget is kind of useless I think 

 

 

the problem is the “all” filter, that shows too many pics on iOS and then breaks the gallery item, or if a single gallery has more than 32 items it breaks also. I just can please elementor to react. 🙏

 

 

 

 

Userlevel 1

So if someone from elementor really take care and read this - please contact me 😎 that would show you as company really care about fixing bugs ✌️

Userlevel 1

Hi Jakob, 

Has this been solved for you, or is it marked as ‘solved’ because of your work around?

I’m currently experiencing something similar. I’m using the Gallery Widget, uploading all my pictures, the website loads the picture but when I come to view them in the light box, on mobile, the website leads to an error and doesn’t load.

However, I tried your workaround, having less than 25 pictures, and it worked! 

Have you found the reason why this is happening? 

Cheers. 

Tom

Userlevel 1
Badge

I am also having an issue with the lightbox with Safari on an iphone XS Max. I have a large image gallery and I get the error message from Safari “A problem repeatedly occurred on ‘[url where my image gallery is]’.”

Userlevel 1

Hi agn1022, 

It’s very annoying, and I can’t find too much information about it apart from this post! At the moment, I will have to deal with the work around, but hopefully they will look into this soon! 

If you find out they have fixed this, or use a better work around, any chance you can update me on this post? 

Cheers 

Tom 

Userlevel 1
Badge

I suspect the issue is with the hardware on some iphone devices when trying to utilize Elementor’s lightbox functionality, and not necessarily the plugin itself. Once I removed some of my photos to make the gallery smaller, the iphone was able to load my collection of images into the lightbox.

 

I experimented on various iphone devices through browserstack before I reduced the quantity of images. Some iphones worked fine, but some of the newer iphones either resulted in the error message I mentioned previously, or the lightbox didn’t work at all, and the browser linked directly to the image file, opening it as a standalone in the same tab.

 

I am not sure if the issue has to do with the quantity of images or the total filesize of all the images in the gallery being sent to the lightbox.

Userlevel 1
Badge +2

Hello, I have the same problem now with over 10 Sites that I have programmed. On all Android devices the galleries work very well but not on the iPhone where the website crashes.

Is this problem solved by Elementor?

Userlevel 1

Hi,

On the versions I’m running Elementor 3.4.3 and Elementor Pro 3.3.6 they’re not, I’m refraining from updating to Elementor 3.4.6 because when I did, about a month ago, my whole site crashed and I had to revert. What version are you guys running?

Cheers. 

Tom

Userlevel 1
Badge +2

Hey, I installed the version Elementor 3.4.6 and Elementor Pro 3.4.2 and on not a single page do the Gallery images work.

I have now found out that this problem only occurs with the new iOS devices and my iPhone 12 with 14.6 version does not have this problem.

P.S. Why is this topic marked solved? Has it been solved?

Userlevel 1
Badge +2

I have also tested it on the  Elementor  3.3.1 and Elementor Pro 3.3.4 Version it also dosent work!!!

Userlevel 1

Hi, 

My device I’m testing on is an iPhone 11 Pro / iOS 14.7.1.

I think it’s been marked as solved due to the workaround of using 25 pictures or less, which isn’t a solution, I’m not sure who has set it as solved maybe the original author, Jakob, has. 

Would be great to get this marked as unsolved and looked into as this must be effecting a lot of people! 

Cheers. 

Tom 

Userlevel 1
Badge +2

In my opinion, this is also not solved, I can not pass this on to my customers so that from now on we can only work with 25 images in the Mobile Gallery.

Does this work on your iPhone 11 Pro / iOS 14.7.1?

Userlevel 1

Hi Walik, 

 

No it does not work on iPhone 11 Pro / iOS 14.7.1

I saw your post on here. 

 and added the link to this post. 

Hopefully someone from the dev team can have a look at this.

 

Cheers. 

Tom

Userlevel 1

He y everyone 

 

I agree, this topic should not be marked as resolved.

I never did. I can’t see a „solved“ in my backend here. 

it would be very nice if the support re-opens the topic again, highly appreciated.

 

At the moment 25 pics are maximum.

i asked the support team and they said they can’t replicate this issue. Maybe they were using a simulator in chrome or did not have the correct device at hand, i believe but do not know... 

 

until this day I could not find a better workaround - and I would not like to buy an extra plug-in for that, causing more issues maybe.

 

i highly appreciate any help from the developers to make  the gallery widget working again.

Together we hopefully solve this issue as it affects a lot of people and I think 

Reply