Question

Pagination showing 404 on Archive pages

  • 16 August 2021
  • 14 replies
  • 503 views

Badge

I have created a Posts list based on Category.
I used the Elementor Archive theme template to display category title and list of posts on that page. I have used 'Archive Post' link. After the template is created the paginations are not working is showing 404 Error.

 

Example:
https://efsignupstg.wpengine.com/category/creating-profile/page/2 - 404 Error


14 replies

Badge

If the url is https://efsignupstg.wpengine.com/category/creating-profile?page=2 then i can see the results. But the issue is the pagination links. Pagination links appending the query params after the url. Attached the image for the reference. For the page links ‘Previous’ or ‘1’ it is showing wrong link since it is added the query params at the end.

 

 

Userlevel 3
Badge +2

This is the URL that’s screwing up.

https://efsignupstg.wpengine.com/category/creating-profile/page/3/?page=2

I tried the URL and in a separate window and it’s still broken.  It has something to do with /page/3/.  Check your link for the 3rd & next pages.  everything else seems to work.

Badge

The pagination is added by Elementor Archive Template. I am getting 404 if we navigate to any page. Check https://efsignupstg.wpengine.com/category/creating-profile/

How to resolve this? or Is there any other way to list all posts based on category.

Userlevel 3
Badge +2

If I click on the links in the posts it works correctly.  It’s something to do with the pagination.  Are you using the elementor pro kit or just the free one.  Any additional plugins for elementor?

I have had this issue a couple of times. It seems to be an issue with the Wordpress reading settings under ‘Blog pages show at most’ conflicting with the amount you set on the archive/posts widget itself. It normally resolves if you set both of these values to the same amount.

 

The setting in the reading settings:

 

 

Widget Settings:

 

 

Hope this resolves it for you.

Userlevel 6
Badge +3

This is the URL that’s screwing up.

https://efsignupstg.wpengine.com/category/creating-profile/page/3/?page=2

I tried the URL and in a separate window and it’s still broken.  It has something to do with /page/3/.  Check your link for the 3rd & next pages.  everything else seems to work.


please create post, assign categories and pull them, this you can do with pages too

I get the same error on my website in the same conditions: I used Archive template which is displayed based on category. Unfortunately, I get 404 error when I try to move to the next page.

I havetried the solution above (the same amount in WP settings and widget settings) and I get the same error.

Do you have any suggestions in order to resolve this issue?

 

I did some research and I found that the error 404 is resolved when you clean the permanent link structure when you visit Settings - Permanent Links. Basically I changed the setting and afterwards I come back to the setting that was default.

Although, I resolved the error 404, the pagination did not work - I cannot move to the next page. As I said  I used an archive template.
Then I realised that the pagination of the widget works in a simple page of wordpress. In fact, the widget I think does not work with elementor templates but only with pages.

Userlevel 6
Badge +6

There is a simple resolution to this problem: when you build archive template you should use Archive Post widget. If you want to display that template in the regular page you should use Posts widget (not archive posts widget). Clear the cache and hit twice save in permalinks.

Thanks for your reply. Good to know about the Archive Post widget.

There is a simple resolution to this problem: when you build archive template you should use Archive Post widget. If you want to display that template in the regular page you should use Posts widget (not archive posts widget). Clear the cache and hit twice save in permalinks.

Probably it solve my problem. thanks 

Userlevel 6
Badge +3

There is a simple resolution to this problem: when you build archive template you should use Archive Post widget. If you want to display that template in the regular page you should use Posts widget (not archive posts widget). Clear the cache and hit twice save in permalinks.

Probably it solve my problem. thanks 

yes let me know if does not works

Userlevel 7
Badge +4

@Sgoel Eightfold did you find your answer here? If so, please consider clicking “Best answer” to help out others. If you found it elsewhere, please share it here so we can mark your answer as the best one, thanks :)

Badge

I know it’s an old thread, but I had the same issue and this answer by Barknet, helped me solve it. 

Thank you so much!

 

I have had this issue a couple of times. It seems to be an issue with the Wordpress reading settings under ‘Blog pages show at most’ conflicting with the amount you set on the archive/posts widget itself. It normally resolves if you set both of these values to the same amount.

 

The setting in the reading settings:

 

 

Widget Settings:

 

 

Hope this resolves it for you.

 

Reply