Question

Elementor Pro Template Kits Do Not Work


Userlevel 3
Badge +1

I have been trying to use/apply one of the new Kit Library Template Kits for nearly a week - with no success.

 

My Elementor/Elementor Pro plugins are up-to-date  . . . I access the Kit Library through my licensed/active site . . . I choose the kit I want/need (in this case, “Music Festival”) and click “Apply Kit”  . . .  

 

What I get is a “Something Went Wrong” message.   When I refresh and try again, I’m get a “Connect To Elementor Template Library” dialogue box.  (I’m already connected, but I click anyway).   I’m then met with “Your license has exceeded the limitation.”   

 

How can my license have exceeded it’s limitation when I’m trying to access the kit via my active/licensed install?  

 

Elementor “Customer Support” has been no help whatsoever.  I’ve tried for days and days to get assistance - and all I’m consistently given are cut-and-paste template responses with no follow-up and no viable solutions.  I’ve even asked it the one Tempalte Kit I need can be forwarded to me in a zip file (while we wait for Elementor’s Developers to get around to fixing this issue).  Once again, I’m met with stone cold silence.

 

So very disappointed in this situation.  :disappointed:


28 replies

The issues is with PHP v8 or above. 

Try to downgrade your php versión to 7 or above.

  • First step: shutdown your server,
  • Second step: change the versión of PHP,  like php 7.4.21 (last version at this time).
  • Third step: run your server.
  • Four step: Try again to add kit library.

If works, put your like down. Thanks. :thumbsup_tone1:

Badge +1

Solved. I am including the link sent to me by Elementor. I had to go into CPanel and enable ZipArchive. Did that and everything starting working perfectly. 

 

https://elementor.com/help/how-to-fix-common-errors-with-kit-library/

Badge

I had the same problem. When I reconfigured the PHP version from 8.0 to 7.4 it worked without problems!

Thanks.  This solved my problem.

Reply