Question

Server Error (Code 403 error)

  • 14 January 2022
  • 5 replies
  • 20 views

I am at my wit's end. I have done absolutely everything, including my hosting company (Bluehost) who whitelisted my IP address - I am still getting that error which won’t let me save any changes to my website.

I checked the Elementor system info and under PHP error log, I got the info pasted below. It appears to be an Elementor issues. Can anyone suggest a fix? I love Elementor but if I cannot make changes to my site it’s a moot point to keep paying for it.

And no, I do not have Wordfence or anything like that. Already researched that option. So here goes the info:

 


 

PHP: 2022-01-12 23:45:15 [error X 1][C:\Users\ksurm\Local Sites\codesprout\app\public\wp-content\plugins\elementor\includes\template-library\manager.php::457] Uncaught Error: Cannot use object of type WP_Error as array in C:\Users\ksurm\Local Sites\codesprout\app\public\wp-content\plugins\elementor\includes\template-library\manager.php:457 Stack trace: #0 [internal function]: Elementor\TemplateLibrary\Manager->import_template(Array) #1 C:\Users\ksurm\Local Sites\codesprout\app\public\wp-content\plugins\elementor\includes\template-library\manager.php(550): call_user_func(Array, Array) #2 C:\Users\ksurm\Local Sites\codesprout\app\public\wp-content\plugins\elementor\includes\template-library\manager.php(582): Elementor\TemplateLibrary\Manager->handle_ajax_request('import_template', Array) #3 [internal function]: Elementor\TemplateLibrary\Manager->Elementor\TemplateLibrary\{closure}(Array, Object(Elementor\Core\Common\Modules\Ajax\Module)) #4 C:\Users\ksurm\Local Sites\codesprout\app\public\wp-content\plugins\elementor\core\common\modules\ajax\module.php(171): call_user_func(Object(Closure), Array, Object(Elementor\Core\Common\Modules\Ajax\Module)) #5 C:\Users\ksurm\Lo [array ( 'trace' => ' #0: Elementor\Core\Logger\Manager -> shutdown() ', )] PHP: 2022-01-14 00:33:04 [notice X 1][C:\Users\ksurm\Local Sites\codesprout\app\public\wp-content\plugins\elementor\core\common\modules\connect\module.php::230] Trying to get property 'email' of non-object [array ( 'trace' => ' #0: Elementor\Core\Logger\Manager -> shutdown() ', )]

 

Clearly - some issue with the “elementor\includes\template-library\manager.php” file that is not functioning properly. I should mention I do have the Pro version.

 

Thanks!

 

Konnie

 

 


5 replies

Same problem here as of today. No changes made except adding a new page. Can edit older pages. Can not edit new page. Any help is appreciated.

Well, turned out it was my host after all. Switched hosting company and am having no issues at all now.

My problem remains. I think it is unique. I only get the error on one page that I am seeking to edit. Any ideas are appreciated.

Have you tried creating another page and see if the issue replicates itself?

Well, I figured out what the problem was. When I created the page I named it and decided to change the name. Elementor doesn’t seem to like that. On a whim I renamed the page to its original name and boom,  I’m back into the ball game.  Thank you for your interest ksurmann .  It is sincerely appreciated.

Reply