Solved

Error message when playing Vimeo videos

  • 29 September 2021
  • 6 replies
  • 148 views

Hi there,

With the recent videos I’ve uploaded on Vimeo, I get an error message when I want to play them with the Elementor video widget on my website.

It still works fine with all of my older videos, but with the new ones, I get the following message when I want to play them: “Sorry. This video does not exist.”

I’m simply copying the video link in the widget, selecting the source as “Vimeo”. If the video is set on “public”, it works fine, but it’s when the video is set on “private” that it doesn’t work - which is odd because , again, it’s working fine with all of my previous videos, it only does it with the recent ones I uploaded.

It also works fine when I use the embed code in html, even when it’s a private video. That’s why it makes me think that it’s a problem with the video widget, and not a problem with Vimeo.

 

Anyone having the same issue? Or any idea about how to fix that? Thanks in advance!

 

Niels

icon

Best answer by Colin F 14 October 2021, 14:00

View original

6 replies

Badge +1

I am having the same problem.

Older videos are showing but the new one I added today displays “Sorry this video does not exist”

Badge

I am having the same issue and I am wondering why not more people are experiencing that.

It is as Brendan has mentioned, it works with older videos of Vimeo but not with newer ones.

Same issue here.

 

Assume a hypothetical URL like:

https://vimeo.com/123456789/1a2b3c4d5e

 

The “new” correct <iframe> link should include the second slug as ?h=1a2b3c4d5e query parameter in the link, but Elementor does not and just generates https://player.vimeo.com/video/132456789:sweat:

This was enough for the “old” Vimeo videos and only require https://player.vimeo.com/video/132456789 , but the new require https://player.vimeo.com/video/132456789?h=1a2b3c4d5e

 

 

Please add that :)

Thank you all for your answers. @aschoerg I contacted Vimeo and they offered a similar fix, but it still doesn’t work for me. I tried both with the video URL I find in the <iframe> code (https://player.vimeo.com/video/xxxx?h=yyyy) and with another URL format (https://vimeo.com/xxxx?h=yyyy) but I still get the same error message when I paste the URL in the Elementor video widget.

Hi, I’ve been hit with same issue.  I couldn’t get the Video element to work but found the WP embed worked in a Text element.  However, I needed to keep the 2 part url and replicated the second part as the ‘h’ parameter.So a URL ended up looking like this:

https://vimeo.com/abcdefg/12345678/?h=12345678

 

As stated above, the older videos have carried on working fine, just newly uploaded ones are affected.

I have reported this to E support and it got escalated up to L3/dev support and logged as an bug, but no indication of fix time.

 

Some Vimeo links related to this here:

https://vimeo.zendesk.com/hc/en-us/articles/4409305565069-Embedded-player-displays-This-video-does-not-exist-message

https://vimeo.zendesk.com/hc/en-us/articles/360042542372-Using-oEmbed-with-private-videos

 

cheers, Colin

@Narbo_ sorry to hear that. You can go to the vimeo video on vimeo and, click on share and look for the html embed code, this shows you the iframe code with the correct link :)

 

@Colin F  Thanks! Hopefully this works as default soon :))

Reply