Question

Can't drag/drop Elementor widgets into page. Unique issue on one computer only.

  • 12 January 2022
  • 2 replies
  • 19 views

Hello, I’m a new member of the forum; I’m based in Victoria BC and I’ve been using Elementor on professional websites for several years. Now I’m teaching WordPress and Elementor to some beginner design students and I’ve hit an issue on one of their computers.

My question may have been asked earlier, but no solution was mentioned. I replied to this post with details on the same apparent problem:

You can look at my reply to the Original Post, and I’m copying it below as well:

--------------------------------------------------------

I’ve been designing with Elementor for several years and have deployed several client websites based on Elementor widgets.

I am currently teaching a class of beginner WordPress/Elementor students. Everyone is using MacOS and running the latest WordPress installation (on a localhost MAMP server). Everyone has installed Elementor and it’s working perfectly.

EXCEPT one user who’s on a MacBook running MacOS Catalina. Her WordPress site works fine when using the Astra block editor. She’s able to import images and do some minimal styling with no editor issues. She has installed Elementor and Essential Elements, and she is able to open her web pages with “Edit with Elementor” and sees the Elementor Editor Loading splash background. Her pages open with the Elementor menus on the left. Pages show the “Drop Widget” sections on the page body. But when trying to drag a widget into the page, the widget doesn’t activate, the target section doesn’t activate, and the widget springs back to the left column. It doesn’t place onto the page. 

We’ve tried all sorts of hacks: freeing up memory, freeing up disk (she has about 15G free disk space), clearing browser history and browser cache, re-installing WordPress, re-installing the Elementor widgets. There’s been no change to the “widgets won’t drag/drop” behavior.

Any suggestions? What should I look for with her installation? Note I have a class full of students who have installed exactly the same software (MAMP/WordPress/Astra/Elementor) on their MacOS machines and they’re doing just fine.

Any help is more than welcome!!!!

Jenn L.

 


2 replies

Having same issue. Works on one computer, not on another. Used to work on either computer.

I’ve been searching around online for “Can’t drag and drop Elementor widgets” and a few people recommend just restarting the computer. I’ll check with my student in the morning and try that out. We’ve tried everything else we can think of.

Reply